Сравнение 2х листов и замена значений

Привет, David.
>> Функция =ВПР()?
> Спасибо, но я не уверен, что она подойдёт для меня. Я имею дело с прайс
> листами, а в них бавает по 20000 строк. Напрмер: Лист 1 содержит 2 столбца
> и
> 12000 строк. Столбец А не имеет строгой последователности(н. 12,13,17,21 и
> тд.) Лист 2 содержить тоже 2 столбца, но в нем 20000 строк и тоже не имеет
> строгой последовательности. В некоторых случаях они даже не
> совпадеют(напр.на
> листе 1 в столбце А1 есть число 1500, но его нет на листе 2 и также бывает
> и
> наоборот, что есть на листе 2 нет на листе 1) меня интересует как можно
> реализовать следуюшее: На листе 1 берется значение ячейки А1 и
> сравниваеться
> со столбцом А1 листа 2. Если есть идентичное совпадение, то тогда значение
> листа 2 переноситься на лист 1 в ячейку B1. (A1 лист 1 = А256 лист 2,
> тогда
> значение B256 перезаписывет значение B1)
А что с функцией ВПР-то не так?
B1=ВПР(A1;Лист2!$A$1:$A$20000;2;0)
И вниз скопировать... Разве это не то, что вам надо?
Если хочется, чтобы при отсутствии значений не выдавало ошибки, то напишите:
=ЕСЛИ(ЕОШИБКА(ВПР(A1;Лист2!$A$1:$A$20000;1;0));"нет
данных";ВПР(A1;Лист2!$A$1:$A$20000;2;0))



Предыдущие сообщения

::2009-04-13 ::Сравнение 2х листов и замена значений

Похожие сообщения

::2009-04-13 ::Сравнение 2х листов и замена значений

::2009-04-14 ::Сравнение 2х листов и замена значений

Сообщения рядом

::2009-04-13 ::Сравнение 2х листов и замена значений

::2009-04-13 ::Re:

::2009-04-15 ::Re: Как убрать в Word точку между словами?

::2009-04-15 ::Как изменить значениz в диапазоне ячеек



Архив эхо-конференции

Страницы ::
1 ::2 ::3 ::4 ::5 ::6 ::7 ::8