Re: Как преобразовать в текст

идея отличная! Но...
заменять 10 на "десять", я так понял, не надо (в тексте исходного сообщения
упоминалась ссылка на ячейку).
потому можно без макросов обойтись
=ЕСЛИ(A1=10;"десять";) - эта формула без смайликов 
а макрос лучше вот так прописать (что бы не было "один0" ):
Sub Макрос1()
Cells.Replace What:="10", Replacement:="Десять", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
ReplaceFormat:=False
Cells.Replace What:="1", Replacement:="Один", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
ReplaceFormat:=False
Cells.Replace What:="3", Replacement:="Три", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
ReplaceFormat:=False
End Sub
т.е. начиная с бОльших разрядов чисел.
--------------------
"Ткачёв О. А." сообщил/сообщила в новостях следующее:
news:Oz1Jc5uvJHA.1088@TK2MSFTNGP04.phx.gbl...
> Sub Макрос1()
> Cells.Replace What:="1", Replacement:="Один", LookAt:=xlPart, _
> SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
> ReplaceFormat:=False
> Cells.Replace What:="3", Replacement:="Три", LookAt:=xlPart, _
> SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
> ReplaceFormat:=False
> Cells.Replace What:="10", Replacement:="Десять", LookAt:=xlPart, _
> SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
> ReplaceFormat:=False
> End Sub
>
> и т.д.



Похожие сообщения

::2009-05-16 ::Re: Как преобразовать в текст

Сообщения рядом

::2009-05-16 ::Re: нТХЯ 2007 + Vista x64

::2009-05-16 ::Re: Как удалить вложенную в книгу панель?

::2009-05-16 ::Re: Вопрос по PowerPoint

::2009-05-16 ::Re: как написать формулу в Excel?



Архив эхо-конференции

Страницы ::
1 ::2 ::3 ::4 ::5 ::6 ::7 ::8