RE: Сложная формула в Excel - pl ease, help me!

Спасибо за ответ, Татьяна, но известный MVP - Microsoft Excel KL уже на
следующий день предложил мне несколько иное решение:
D2:D9 {=МАКС(ЕСЛИ($A$2:$A$9=A2;$B$2:$B$9))}
E2:E9 {=МИН(ЕСЛИ($A$2:$A$6=A2;$C$2:$C$6))}
F2:F9 =ЕСЛИ(B2=D2;D2-E2;0)
B10 =СУММПРОИЗВ(B$2:B$9*(D$2:D$9=B$2:B$9)) сумма макс.
C10 =СУММПРОИЗВ(C$2:C$9*(E$2:E$9=C$2:C$9)) сумма мин.
"Tatyana Ivanova" wrote:
> Привет, Alexander VY.
> > A B C D
> > 1
> > 2 1 150 50
> > 3 1 100 90
> > 4 1 75 110
> > 5 2 500 200
> > 6 2 300 250
> >
> > в B1 должно быть - сумма по промежуточным итогам максимальных значений
> > ячеек B с одинаковыми значением А = 150 + 500 = 650
>
> Могу предложить следующий вариант решения. В D2
> =МАКС(--($A$2:$A$6=A2)*($B$2:$B$6))/СЧЁТЕСЛИ($A$2:$A$6;A2) и нажимаете
> Ctrl+Shift+Enter,
> то есть это формула массива. Затем копируете ее на D3:D6
>
> В D1 находите сумму по столбцу.
>
> >
> > в С1 должно быть - сумма по промежуточным итогам минимальных значений
> > ячеек
> > С с одинаковыми значениями А, т.е.=50+200=250
>
> Аналогично, только формула:
> =МИН(ЕСЛИ(--($A$2:$A$6=A2)*($C$2:$C$6)=0;"";--($A$2:$A$6=A2)*($C$2:$C$6)))/СЧЁТЕСЛИ($A$2:$A$6;A2)
>
> > в D3 должна быть разность масимального значения В и минимального значения
> > С
> > с одинаковым значением А, т.е. 150 - 50 = 100, то же самое в D6 = 500 -
> > 250 =
> > 250, при этом D4, D5, D7 должны быть равны 0, т.е. если разность уже
> > найдена,
> > то в остальных строках по столбцу D с тем же значением А, что и в
> > найденной
> > разности должен быть 0.
>
> Тут ничего предложить не могу. В каждой строке можно считать, это см.
> формулы выше.
>
> .
>




Предыдущие сообщения

::2010-04-13 ::Сложная формула в Excel - please , help me!

::2010-04-21 ::Сложная формула в Excel - please , help me!

Ответы

::2010-04-30 ::Re: Сложная формула в Excel - pl ease, help me!

Похожие сообщения

::2010-04-30 ::RE: Сложная формула в Excel - pl ease, help me!

::2010-04-30 ::Re: Сложная формула в Excel - pl ease, help me!



Архив эхо-конференции

Страницы ::
1 ::2 ::3 ::4 ::5 ::6 ::7 ::8